db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: Options for syncing of log to disk
Date Tue, 05 Sep 2006 07:33:49 GMT
Suresh Thalamati <suresh.thalamati@gmail.com> writes:

> Knut Anders Hatlen wrote:
>> Mike Matrigali <mikem_app@sbcglobal.net> writes:
>>
>>
>>>I actually don't even know if
>>>we have ever run a set of tests on freebsd. I wonder if anyone in
>>>the comunity has tried out the 10.2 beta on feebsd?  Just the
>>>results of a nightly test run would be interesting.
>>
>>
>> I frequently run derbyall on FreeBSD 6.1. With Diablo JDK 1.5.0-7
>> (native JDK built on J2SE 5.0 update release 7), the upgrade test
>> fails to boot the database because of a FileNotFoundException (but the
>> error message says "file exists").
>
>
> Thanks for running tests on FreeBsd, Knut. It is a good addtion  to
> the list of platforms the derby is tested on,
>
> The error you are seeing in the uprade test failures seems to be
> similar to the ones seen on Mac
> (DERBY-1(http://issues.apache.org/jira/browse/DERBY-1)) in version
> 10.0 while creating a database on some versions of JVMS. . I vaguely
> remember reading some where on the internet that  "rws" fails on
> FreeBSD too, on some jvm versions.  DERBY-1 was addressed in 10.1,
> with an workaround fix that changes the defaullt log file writes to
> file sync, if a FileNotFoundException occurs during a file creation
> with write sync.
>
> May be the upgrade test is failing while creating a database in
> version 10.0 using write sync ("rws"), while testing upgrade from 10.0
> to 10.1 ; just a wild guess.

Thank you, Suresh, the error I see is indeed DERBY-1. The upgrade test
fails when it tries to create a 10.1 database. I was under the
impression that the upgrade test used 10.1.2.1 (in which DERBY-1 is
fixed), but it is the 10.1.1.0 jars that are used. When I ran the
upgrade test with derbyTesting.jar.path pointing to a location which
contained 10.1.2.1 jars, it ran cleanly.

I have reported the issue to the FreeBSD Java team
(http://www.freebsd.org/cgi/query-pr.cgi?pr=102888).

-- 
Knut Anders

Mime
View raw message