db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John H. Embretsen (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-1846) Create a script that allows users to easily update their Derby jars with the JDBC4 classes.
Date Thu, 21 Sep 2006 15:18:23 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1846?page=comments#action_12436552 ] 
            
John H. Embretsen commented on DERBY-1846:
------------------------------------------

I tried the script again (from an updated trunk) on Solaris 10 x86, bash shell (version 3.00.16),
and after doing the double-to-quadruple-backslash fix (at two places in the script), I get
the following error:

--------8>---------------------------------------
Compiling the client classes for JDBC 4.0
/home/user/apache/Derby/clean/trunk/java/client/org/apache/derby/client/net/NetConnection.java:43:
org.apache.derby.client.net.NetConnection is not abstract and does not override abstract method
createStruct(java.lang.String,java.lang.Object[]) in java.sql.Connection
public class NetConnection extends org.apache.derby.client.am.Connection {
       ^
Note: /home/user/apache/Derby/clean/trunk/java/client/org/apache/derby/client/net/NetConnection.java
uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
1 error
There was an error compiling the client classes. Exiting.
--------8>---------------------------------------

Not sure yet what is causing this. Could it be a user error? I hope someone else is able to
try it on Solaris as well...

I also tried the updated batch script on Win XP, and it went fine - at least the jdbc40 suite
passes in both Embedded and DerbyNetClient frameworks. The only thing I wanted to comment
is that the script started out by reporting "The system cannot find the file specified", which
is caused by trying to remove a %DERBY_HOME%\jdbc4classes directory that does not exist yet.
No big deal, its just something that may scare users (unless it is documented properly).



> Create a script that allows users to easily update their Derby jars with the JDBC4 classes.
> -------------------------------------------------------------------------------------------
>
>                 Key: DERBY-1846
>                 URL: http://issues.apache.org/jira/browse/DERBY-1846
>             Project: Derby
>          Issue Type: Improvement
>          Components: Demos/Scripts
>    Affects Versions: 10.2.1.0
>            Reporter: Andrew McIntyre
>         Assigned To: Andrew McIntyre
>             Fix For: 10.2.1.0
>
>         Attachments: derby-1846-v1.diff, derby-1846-v2.diff, derby1846-batchFix_v1.diff,
modules.properties, output_batchFix_v1.txt
>
>
> Since the resolution of the JDBC 4 licensing issue was to not ship a build that includes
Derby's JDBC 4 code, but continue to ship the Derby source files for them, a script which
automatically compiles and updates the Derby jars with the JDBC 4 classes would be useful.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message