db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject running derbyall against 10.2.1.5 on jdk 1.6
Date Mon, 25 Sep 2006 20:43:59 GMT
I saw the following failures when I ran derbyall against 10.2.1.5 on jdk 
1.6. I believe that these failures should be expected and I take them as 
evidence that the release candidate presents our JDBC3 drivers when run 
on jdk 1.6:

The following tests failed initially, but passed when I removed the 
jdk16-specific canons and allowed them to diff against the 1.4 canons:

closed
grantRevokeDDL2
procedureInTriger
releaseCompileLocks

DerbyNet and DerbyNetClient checkSecMgr
DerbyNet and DerbyNetClient procedure
DerbyNet and DerbyNetClient importExport
DerbyNet and DerbyNetClient ieptests
 
The following tests correctly reported that the JDBC rev level was 3.0 
even though the test expected 4.0 when run on jdk1.6:

dbMetaDataJdbc30
DerbyNetClient dbMetaDataJdbc30

Otherwise, the tests ran cleanly on jdk 1.6.

Regards,
-Rick


Mime
View raw message