db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Re: [jira] Commented: (DERBY-1846) Create a script that allows users to easily update their Derby jars with the JDBC4 classes.
Date Thu, 21 Sep 2006 20:16:23 GMT
John H. Embretsen wrote:

> Daniel John Debrunner wrote:
>
>>> Rick Hillegas commented on DERBY-1846:
>>> --------------------------------------
>>>
>>> I'm afraid I don't understand the workaround. It appears that John 
>>> regenerated all of the jars from scratch. 
>>
>
> I was doing that to "simulate" a 10.2.1.x bin-distribution, i.e. jars 
> without JDBC 4. Since my sources were out of sync with the non-JDBC 
> jars that were to be updated, the compiler complained.

Hm. I'm working with a 10.2.1.4 distribution built without JDBC4 classes 
by the release generation machinery. I'm still seeing the compiler 
problem on NetConnection when I run the update-with-jdbc4 script.

>
>>> If we're going to do that, then why are we writing this script in 
>>> the first place? Why don't we just tell the users:
>>>
>>> 1) Unzip the source distribution.
>>>
>>> 2) Point ant.properties at your JDK 6 installation.
>>>
>>> 3) Build Derby.
>>
>>
>> If it's as simple as that, why do we need another script?
>>
>> Dan.
>>
>
> I think it was mainly so that users won't have to download ant, set it 
> up and do all the other things required by BUILDING.txt. See
> http://issues.apache.org/jira/browse/DERBY-1846#action_12434544.
>
> The scripts are very useful, but not strictly necessary. See the 
> description for DERBY-1846.
>
>


Mime
View raw message