db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Susan L. Cline" <home4...@pacbell.net>
Subject Re: Running a Derby JUnit test using JUnit directly
Date Fri, 01 Sep 2006 17:18:52 GMT
--- Myrna van Lunteren <m.v.lunteren@gmail.com> wrote:

> On 9/1/06, Daniel John Debrunner <djd@apache.org> wrote:
> > Vemund Ostgaard wrote:
> >
> > > For the jobs doing nightly testing on the 10.2 branch we did a short
> > > term workaround by copying derbyTesting.jar to its old location, to
> > > avoid other changes. So, thats why it hasn't failed in those tests.
> >
> > It's good to report such problems, not just work-around them. That way
> > others get to know and the issue can be fixed quicker.
> >
> > Or maybe I missed the e-mail discussing this?
> > Dan.
> >
> >
> This is a good catch - I had just continued my practice from earlier
> versions to copy all derby*.jar files to one location and set my own
> classpath, I never thought about verifying with the split set-up.
> 
> I think the harness/policyfile should work either way...
> 
[ snip]

I'm still trying to figure out if there is a way to run a JUnit test standalone
against the jars.  What I am trying to do is to test the 10.2 beta release using
a derbyTesting.jar I built in the development branch (10.3).  I'm trying to use the
class I created to test the functionality of something in the 10.2 beta release
without having to check out the 10.2 branch(trunk? sorry I don't know the terminology
here.)

So here's what I have;

lib directory with all of the derby jar files from the 10.2 release EXCEPT the derbyTesting.jar

I copied over the derbyTesting.jar I created from the 10.3 trunk to the lib directory

I've tried various combinations / permutations of running my JUnit test standalone and can
not
succeed.  The wiki entry, http://wiki.apache.org/db-derby/DerbyJUnitTesting, says, 
'The classpath needs to include the junit.jar and the Derby classes.'

So is there anyway to run it just using the jar files and not the classes directory?

Some of the things I've tried are including the derby.system.home on the command line and
having a derby_tests.policy file in derby home, and not having the derby_tests.policy file
in derby.system.home.  I've passed the classpath on the command line, and set it as an
environment variable - sometimes I get 'NO SUITABLE DRIVER' errors, other times I don't.

Thanks,

Susan

Mime
View raw message