db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "V.Narayanan (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-1547) Add svn version number to DatabaseMetaData getDatabaseProductVersion and getDriverVersion() to improve supportability
Date Tue, 12 Sep 2006 05:47:23 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1547?page=comments#action_12434066 ] 
            
V.Narayanan commented on DERBY-1547:
------------------------------------

I am sorry for my previous comment. I got confused. I am able to reproduce the error u are
seeing if I change the sed scripts to the following

I go the sed scripts and modify them as

substitute=....[0-9][0-9][0-9][0-9][0-9][0-9][0-9]*[A-Z].;-(1),version [0-9][.][0-9]..[0-9][.][0-9][.][0-9][0-9]?[0-9]?.[A-Za-z
]*.$;version (EXPECTED VERSION),version [0-9][.][0-9]..[0-9].[0-9].[0-9][0-9]? Test Build.$;version
(EXPECTED VERSION),getDriverVersion....[2-3].*$;getDriverVersion(): EXPECTED VERSION

If u notice the first regular expression change

....[0-9][0-9][0-9][0-9][0-9][0-9][0-9]*[A-Z].;-(1)

-- listing properties --
derby.language.statementCacheSize=1000
*** Start: metadata jdk1.4.2 DerbyNetClient 2006-09-12 11:15:24 ***
Initialize for framework: DerbyNetClient
java -Duser.language=en -Duser.country=US -Dderby.system.home=/home/guest/Narayanan/tests/run1/DerbyNetClient/metadata
-Djava.security.manager -Djava.security.policy=/home/guest/Narayanan/tests/run1/derby_tests.policy
-DderbyTesting.codeclasses=file:/home/guest/Narayanan/derby_workspaces/DERBY-1547-sed-patch-applied/trunk/classes/
-DderbyTesting.codedir=/home/guest/Narayanan/derby_workspaces/DERBY-1547-sed-patch-applied/trunk/classes
-DderbyTesting.serverhost=localhost -DderbyTesting.clienthost=localhost org.apache.derby.drda.NetworkServerControl
start
Attempt to shutdown framework: DerbyNetClient
16 del
< JDBC Driver 'Apache Derby Network Client JDBC Driver', version 10.3 (10.3.0.0 alpha-(EXPECTED
SUBVERSION INFO))
16a16
> JDBC Driver 'Apache Derby Network Client JDBC Driver', version 10.3 (10.3.0.0 alpha-(1))
152 del
< getDatabaseProductVersion(): 10.3.0.0 alpha-(EXPECTED SUBVERSION INFO)
153 del
< getDriverVersion(): 10.3.0.0 alpha-(EXPECTED SUBVERSION INFO)
153a152,153
> getDatabaseProductVersion(): 10.3.0.0 alpha-(1)
> getDriverVersion(): 10.3.0.0 alpha-(1)
Test Failed.

Can you please answer the following questions for me

1) Is this behaviour observed by you when running only with the classes directory or when
running with the jars also?
2) After applying the patch can you please open the metadata_sed.properties to see if the
replacement pattern is (EXPECTED SUBVERSION INFO) or (1)

Narayanan

> Add svn version  number to DatabaseMetaData getDatabaseProductVersion and getDriverVersion()
 to improve supportability
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-1547
>                 URL: http://issues.apache.org/jira/browse/DERBY-1547
>             Project: Derby
>          Issue Type: Improvement
>          Components: JDBC
>    Affects Versions: 10.1.3.2
>            Reporter: Kathey Marsden
>         Assigned To: V.Narayanan
>            Priority: Minor
>             Fix For: 10.2.1.0
>
>         Attachments: DERBY-1547-sed.diff, DERBY-1547-sed.stat, DERBY-1547_v1.diff, DERBY-1547_v1.stat,
derbyall_fail.txt
>
>
> getDatabaseProductVersion and getDriverVersion() report only the four digit Derby version
number and not the svn build number.   It would be useful to return  the full version including
the build number  as sysinfo does: e.g. "10.1.2.4 - (392472)", That way it will be clear from
application logs that collect this information exactly what revision level they are running
if they are using rolled up fixes on the maintenance branch between releases.
> There may be risk in doing this however if applications are parsing the version information,
but hopefully they will use getDatabaseMajorVersion() , getDatbaseMinorVersion, getDriverMajorVersion,
and getDriverMinorVersion for such proccessing.  

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message