db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepa Remesh" <drem...@gmail.com>
Subject Re: [jira] Commented: (DERBY-1746) upgrade tests should start using 10.1.3 released builds
Date Thu, 24 Aug 2006 21:07:57 GMT
On 8/24/06, Rick Hillegas (JIRA) <derby-dev@db.apache.org> wrote:

> In addition, I don't think we should be running a test called 10_1_10_2 in the trunk.
We should be running some other tests, perhaps 10_1_to_Current and 10_2_to_Current in the
trunk. Perhaps 10_1_10_2 becomes the basis for 10_1_to_Current.

Upgrade_10_1_10_2 has been removed from running as part of derbyall in
the trunk. DERBY-1689 is open for adding new upgrade tests for trunk.
Instead of adding a new test for testing upgrade from 10.1, I now
think it is better to rename Upgrade_10_1_10_2 to Upgrade_From_10_1.
This way, we can use the same test in 10.2 and trunk. In the test's
version in trunk, we will need to change the "new version" to 10.3.

Later once 10.2 jars are released, we can similarly create a new test
Upgrade_From_10_2 and make it part of trunk. This test can then be
used in all later 10.x versions.

If this sounds okay, I'll submit patch to rename the current upgrade
test and attach it to DERBY-1689.

Thanks,
Deepa

Mime
View raw message