db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kim Haase <Camilla.Ha...@Sun.COM>
Subject Re: Doc reviews: should the internal links for the PDFs work?
Date Thu, 31 Aug 2006 18:19:49 GMT
Andrew McIntyre wrote On 08/30/06 20:23,:
> On 8/30/06, Laura Stewart <scotsmatrix@gmail.com> wrote:
> 
>>>When I click on those links with the HTML pages version of the doc they do work.
>>>Is this a general (known) problem?  Or is this a problem with this specific section
>>>that I need to report in the doc review?
>>
>>Susan - this is a problem with only the Alpha versions of the docs. In
>>the 10.1 PDF versions the links work just fine.  There is another
>>problem with the Alpha versions, they do not display the graphic
>>files.  These problems must be as a result of some setting in the
>>build for the Alpha versions.
> 
> 
> They should work, but it looks like another problem with our custom
> dita2fo-shell.xsl stylesheet's handling of internal links.
> 
> Please file a JIRA for it. This will be a fairly involved fix to the
> stylesheet and I don't know if I'll have time to get to it before the
> release.
> 
> Thanks,
> andrew

I looked into the graphics file issue yesterday and was going to file a
JIRA issue on it. I think this is the problem:

* The HTML Pages use the GIF files from the src directory, which are
copied into the out directory during the build (for the two books that
use graphics, devguide and tuning).

* The PDF and HTML one-pager seem to expect the JPG versions of the
files, which are not copied into the out directory during the build. If
I manually copy them over, the graphics show up.

I expect the graphics issue is separate from the links issue. Should it
have a separate JIRA issue? It might be an easier problem. If so, Laura
can file the links one and I can file this one.

There's yet another small graphics issue in that one of the GIF files
has a misspelled name -- it's called ptsmt_os.gif instead of
pstmt_os.gif -- so it doesn't get copied over at all. I guess that's yet
another issue.

Thanks,
Kim


Mime
View raw message