db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Re: [jira] Commented: (DERBY-1746) upgrade tests should start using 10.1.3 released builds
Date Fri, 25 Aug 2006 17:36:13 GMT
Thanks, Myrna. I will have to take this up again later: I've got my head 
down in the 10.2 merge and build now. I seem to recall that, without 
this patch, I was able to run the upgrade test against the classtree. 
But perhaps I am mistaken.

Cheers,
-Rick

Myrna van Lunteren wrote:

> On 8/25/06, Rick Hillegas (JIRA) <derby-dev@db.apache.org> wrote:
>
>>    [ 
>> http://issues.apache.org/jira/browse/DERBY-1746?page=comments#action_12430508 
>> ]
>>
>> Rick Hillegas commented on DERBY-1746:
>> --------------------------------------
>>
>> I have now tried to apply this patch as follows:
>>
>> cd tools/testing
>> svn propedit svn:externals . (editting the 10.1 version to be 10.1.3.1)
>> cd ../..
>> svn update
>> ant clobber
>> ant all
>>
>> When I run the Upgrade_10_1_10_2 test I get pages of diffs and the 
>> following exception:
>>
>> 2956 add
>> > java.lang.ExceptionInInitializerError
>> > Caused by: java.lang.SecurityException: sealing violation: can't 
>> seal package org.apache.derby.iapi.services.crypto: a
>> lready loaded
>>
>> Would appreciate advice on what I am doing wrong.
>>
>
> I did the same thing and saw the same thing...
> But then I tought I remembered the upgrade tests only work with jars;
> when I did ant buildjars & set my classpath to use the jars the test
> passed again.
> Again, apologies for giving incomplete details, in this case I thought
> it was a stupid mistake on my part that I tried to run with classes.
>
> If I was doubly confused, and this test is supposed to work with
> classes also, then we may need to look into this cryptic crypto
> sealing error some more...
>
> Myrna



Mime
View raw message