db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Re: Release signing oddities
Date Fri, 11 Aug 2006 14:55:07 GMT
Thanks Kathey and Andrew for your quick responses.

Andrew McIntyre wrote:

> On 8/10/06, Rick Hillegas <Richard.Hillegas@sun.com> wrote:
>
>> I'm seeing the following behavior when running the "ant sign" target
>> from tools/release. I'm running on cygwin. Would appreciate advice.
>>
>> md5.options=-n
>
>
> It would be good to note that this is the correct option for Cygwin on
> the SnapshotAndRelease page.

Will do.

>
>> 2) I'm using gpg as my signing tool. This is the default setting of
>> pgp.exec in packaging.tmpl. The default pgp.options there are
>> "--detach-sign --armor". All well and good when I run gpg standalone
>> from the command line. Then I get an output file which looks like the
>> pgp output attached to the 10.1.3 release. However, when I run "ant
>> sign", ant hangs when it gets to the pgp target. I think that ant is
>> hanging because gpg wants to query me for my passphrase. Does anyone
>> know how to get ant unstuck here?
>
>
> Kathey reported this as well, I think Ant on Windows won't print the
> gpg password prompt. You could try typing your password in eight time.
> Or just sign the jars using the script at the end of #11 on the
> SnapshotAndRelease page.

I think I'll have to do this by hand.

>
> Are you planning on putting this on the mirrors? It's ok if you do,
> there are other betas currently distributed through the mirrors, and
> it's definitely a good idea to do so if you think it will get a lot of
> traffic, but I'm curious if that was actually your intention.
>
> andrew

It's probably a good thing to do and I should learn this magic too. I'm 
going to start out publishing the beta to my public_html directory.

Thanks again,
-Rick

Mime
View raw message