db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick Hillegas <Richard.Hille...@Sun.COM>
Subject Release signing oddities
Date Fri, 11 Aug 2006 00:22:09 GMT
I'm seeing the following behavior when running the "ant sign" target 
from tools/release. I'm running on cygwin. Would appreciate advice.

1) The default md5.options from tools/ant/packaging.tmpl is "-q". On 
cygwin this produces md5 output consisting of a hash followed by a 
filename. I notice that this is not the md5 output attached to the 
10.1.3 release. The 10.1.3 md5 output is just a hash. I can get this 
output by setting the following variable in my ant.properties:

md5.options=-n

2) I'm using gpg as my signing tool. This is the default setting of 
pgp.exec in packaging.tmpl. The default pgp.options there are 
"--detach-sign --armor". All well and good when I run gpg standalone 
from the command line. Then I get an output file which looks like the 
pgp output attached to the 10.1.3 release. However, when I run "ant 
sign", ant hangs when it gets to the pgp target. I think that ant is 
hanging because gpg wants to query me for my passphrase. Does anyone 
know how to get ant unstuck here?

Thanks,
-Rick

Mime
View raw message