db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Army <qoz...@gmail.com>
Subject Re: DERBY-688: Is this a build problem? a CLASSPATH problem? a security problem?
Date Sat, 05 Aug 2006 17:21:32 GMT
Bryan Pendleton wrote:
> Hi Army,
> 
> I believe I've successfully applied the XML patches in
> DERBY-688 and built them using the normal build techniques
> that I use for Derby.
> 
> When I try to run, I see the exception below.
> 
> org.apache.xml.utils.WrappedRuntimeException: The resource [ 
> file:////org/apache/xalan/serialize/XMLEntities.res ] could not load: 
> java.security.AccessControlException: access denied 

Can I ask what version of Xalan you are using?  You should be able to figure 
this out by following the directions here:

http://xml.apache.org/xalan-j/faq.html#environmentcheck

If you are just using the version that is part of Sun jdk 1.4.2, then I think 
there is a bug in that version of Xalan that is causing this error.  I think 
it's related to XALANJ-1643 (type that in your Jira "Quick Search" box) and has 
been fixed in Xalan version 2.5 and later (based on the comments in that issue).

When I removed my external version of Xalan and just ran with the one that's 
embedded in Sun 1.4.2, I see this error, too.  When I take the steps to override 
  the jdk's version (which is a bit odd; see:

http://xml.apache.org/xalan-j/faq.html#faq-N100D6)

with a newer version (I'm using 2.6), the problem goes away.

Does this solve the problem for you?

Thanks for bringing this up--I guess we are either going to have to document 
that Xalan 2.5 (or whatever the specific version is) is required in order for 
this to work, or else I'm going to have to figure out an alternative.  But that 
said, I think this is just an issue when running with SecurityManager; I tried 
to run some of the SQL/XML statements in the tests manually and they all worked; 
my manual tests did not use the SecurityManager.

Please let me know if the above solution works for you, or if you have any other 
problems.  Thanks for trying this out and for your patience as we track this down...

Army


Mime
View raw message