db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew McIntyre (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-1002) Check that DRDAStatement and DRDAResultSet states are reset when they are re-used
Date Tue, 13 Jun 2006 06:12:30 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1002?page=comments#action_12415957 ] 

Andrew McIntyre commented on DERBY-1002:
----------------------------------------

This has been partially fixed in 10.1.3. I'm thinking the right thing to do is mark it affects
10.1.3, then move the FixIn for the issue out to 10.1.4 and make a note of the partial fix
in the release notes. Unless anyone has any objections, that's the course I'll take when putting
together the release notes.

> Check that DRDAStatement and DRDAResultSet states are reset when they are re-used
> ---------------------------------------------------------------------------------
>
>          Key: DERBY-1002
>          URL: http://issues.apache.org/jira/browse/DERBY-1002
>      Project: Derby
>         Type: Bug

>   Components: Network Server
>     Reporter: Deepa Remesh
>      Fix For: 10.2.0.0, 10.1.3.0
>  Attachments: derby1002-patch1-draft1.diff, derby1002-patch1-draft1.status, derby1002-patch1-v1.diff,
derby1002-patch1-v1.status, derby1002-patch2-v2.diff, derby1002-patch2-v2.status, derby1002.java
>
> Network server re-uses DRDAStatement and DRDAResultSet objects when client sends a request
with same section number. When re-using DRDAStatement, it's close() method is called which
inturn calls close() method of DRDAResultSet. For re-use to work properly, we have to ensure
the states of these objects are reset. This is not a bug but it is an area for possible improvements
like:
> * The reset of all states are not in the close() methods. The states get re-initialized
at different places in the code. Fo example, in case of DRDAResultSet, they get initialized
in some other DRDAStatement methods - like addResultSet, setRsDefaultOptions, setOPNQRYOptions,
setQueryOptions etc. It will be good to have all resets in one method.
> * The method name "close" is confusing since it is also called when objects get re-used.
For clarity, it may be good to have a method named reset(). And then have the close method
call reset.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message