db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew McIntyre (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-892) add mechanism for specifying policy file for individual function tests
Date Wed, 24 May 2006 04:59:30 GMT
    [ http://issues.apache.org/jira/browse/DERBY-892?page=comments#action_12413064 ] 

Andrew McIntyre commented on DERBY-892:
---------------------------------------

This looks good, but shouldn't we leave the permissions needed for running tests in useprocess=false
mode in the base harness policy file, considering the recent work that was done with DERBY-1141?
Since the permission is only granted on derbyTesting.jar, the tests are still quite secure
when running in from the jars. You could have the harness append the necessary permissions
if running in useprocess=false mode, but that might be more trouble than its worth. Also,
this makes the lang/errorStream.policy file unnecessary, unless you choose to go the append-permissions-for-useprocess=false
route.

> add mechanism for specifying policy file for individual function tests
> ----------------------------------------------------------------------
>
>          Key: DERBY-892
>          URL: http://issues.apache.org/jira/browse/DERBY-892
>      Project: Derby
>         Type: Bug

>   Components: Test
>     Versions: 10.2.0.0
>     Reporter: Myrna van Lunteren
>     Assignee: Myrna van Lunteren
>     Priority: Minor
>  Attachments: DERBY-892_20060514.diff, DERBY-892_20060514.stat, DERBY-892_3_20060523.diff,
DERBY-892_3_20060523.stat, derby-892_pre.diff
>
> It would be nice to be able to specify a test-specific policy file.
> This should get handled similar to existing properties, i.e. get specified in a test_app.properties
file (or, for a suite, in the suite.properties file).  The file should then be copied into
the correct place.
> Note, that the 'old' functionTests harness (as opposed to junit tests) includes a check
for a property called 'serverPolicyFile' (in harness/jvm.java). The name is a left over from
when the policy file was only used for/by network server, and should be renamed - derbyTestPolicyFile,
for instance. It is not used anywhere at present, and not specific to network server. It would
be nice if this could be expanded, or, if not used, removed.
> The default policy file used is the derby_tests.policy file under functionTests/util.
> Also, currently, the property can only be used with RunTest - for further traction, it
should probably get passed on through RunSuite/RunList.
> Once confirmed to be working, the property should get documented in <trunk>/java/testing/README.htm.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message