db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@apache.org>
Subject Re: SqlExceptionTest failure on JDK 1.3 platforms ...
Date Fri, 19 May 2006 21:13:29 GMT
Andrew McIntyre wrote:
> On 5/19/06, David Van Couvering <David.Vancouvering@sun.com> wrote:
> 
>> What does it mean to be a "recently modified person?" :)
>>
>> I was the one who wrote this (quite a while ago, actually), and you're
>> right, as it stands it won't run on JDK 1.3.
>>
>> However, I think there is value in testing the getNextException()
>> methods on JDK 1.3.  Can't we test for the JDK version in the test and
>> exclude the tests of getCause() if it's JDK 1.3?
> 
> 
> Yes. Import org.apache.derby.iapi.service.info.JVMInfo, then wrap the
> offending calls in:
> 
> if (JVMInfo.JDK_ID >= JVMInfo.J2SE_14) { ... }

Except that tests should not be using internal Derby classes.

Dan.


Mime
View raw message