db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Van Couvering <David.Vancouver...@Sun.COM>
Subject Re: SqlExceptionTest failure on JDK 1.3 platforms ...
Date Fri, 19 May 2006 20:38:28 GMT
What does it mean to be a "recently modified person?" :)

I was the one who wrote this (quite a while ago, actually), and you're 
right, as it stands it won't run on JDK 1.3.

However, I think there is value in testing the getNextException() 
methods on JDK 1.3.  Can't we test for the JDK version in the test and 
exclude the tests of getCause() if it's JDK 1.3?

David

Satheesh Bandaram wrote:
> Sounds like a good approach... Any interest from the writers or recently 
> modified persons to exclude this test on 1.3? If no one has this itch, I 
> probably will address this test issue.
> 
> Satheesh
> 
> On 5/19/06, *Rick Hillegas* <Richard.Hillegas@sun.com 
> <mailto:Richard.Hillegas@sun.com>> wrote:
> 
>     Hi Satheesh,
> 
>     It looks to me like this is a new test introduced by revision 386710 to
>     close DERBY-1117. Testing getCause() appears to be central to what this
>     test wants to verify. Maybe we shouldn't run this test on 1.3.
> 
>     Regards,
>     -Rick
> 
>     Satheesh Bandaram wrote:
> 
>      > Looks like this test was modified to use getCause() method, which is
>      > not supported in JDK 1.3 platforms. This causes the test to fail.
>     What
>      > should be done to fix the failure on JDK 1.3 ?
>      >
>      > Satheesh
> 
> 
> 

Mime
View raw message