db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stanley Bradbury <Stan.Bradb...@gmail.com>
Subject Re: Feedback integrate/plugin_howto.html
Date Thu, 11 May 2006 00:56:37 GMT
Joe Dorocak wrote:

>Dear Derby-Dev,
>
>Regarding your article "Using the 10.1 Core and 1.1 UI Derby plug-ins" at
>URL
>http://db.apache.org/derby/integrate/plugin_howto.html#Installing+the+plug-i
>ns
>
>I have tried to install the Derby plugins twice now, without success. 
>
>I checked the md5 sums for both "derby_core_plugin_10.1.2.zip" and
>"derby_ui_plugin_1.1.0.zip". They were both OK.
>
>I unzipped them both into "C:\eclipse", my ECLIPSE_HOME, as a result there
>are 3 new subdirectories under "C:\eclipse\plugins":
>
>  org.apache.derby.core_10.1.2
>
>  org.apache.derby.plugin.doc_1.1.0
>
>  org.apache.derby.ui_1.1.0
>
>However, after restarting eclipse, Version: 3.1.2, Build id: M20060118-1600,
>"Apache Derby" does NOT show up in the menu when I right-click on my
>project.
>
>Additionally, under Help>>About Eclipse SDK>>Plug-in Details, when I sort
on
>"Plug-in Id", "org.apache.axis" is followed by "org.apache.lucene" and NOT
>by "org.apache.derby.core" and the 2 other derby items, as I expected.
>
>I hope you can help me. If you want, I can provide a listing of the
>directory contents of the derby plugins, as well as a listing of the
>relevant "plugin.xml"s. 
>
>Thanks in advance.
>
>Regards,
>
>
>Joe Dorocak
>joe@theocom.com
>
>
>
>  
>
Hi Joe -
You may have already seen this but your issue is very close to the 
problem posted by JavaJosh earlier with the same subject line.  The 
archive of the begining report is at:
http://mail-archives.apache.org/mod_mbox/db-derby-dev/200605.mbox/%3c44617D2F.9080504@joshrehman.com%3e
There were responses which I do not see in the archives yet so am 
pasting here in case it is of help:

home4slc@pacbell.net wrote:

Hi, 

>>From the output you've shown below it appears that you have the 3 plugins installed,
however I'm not sure why you are having the problem.  The version of Eclipse I have is 3.1.0.
 
When I look at the configuration details of my installation it shows all three plugins in
the registry as well as in the configured plugins section.  I noticed it does not show
the UI or Doc plugins in the registry section for you.
 
Later today I'll install 3.1.2 and see if I run into the same problems you are.
 
As a quick suggestion that might help, try restarting eclipse with the -clean option.
 
"eclipse.exe -clean"
 
Thanks,
 
Susan

========================
Rajesh Kartha wrote:

 Can you also look in the workspace log file if there are any 
errors/exceptions. In your case the file
should be:

C:\bin\eclipse\workspace\.metadata\.log
Any reason for not loading/starting the plug-ins will typically be 
written to this .log file.

-Rajesh


Mime
View raw message