db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myrna van Lunteren (JIRA)" <derby-...@db.apache.org>
Subject [jira] Updated: (DERBY-892) add mechanism for specifying policy file for individual function tests
Date Wed, 24 May 2006 04:29:30 GMT
     [ http://issues.apache.org/jira/browse/DERBY-892?page=all ]

Myrna van Lunteren updated DERBY-892:

    Attachment: DERBY-892_3_20060523.stat

Attaching a follow-up patch - DERBY-892_3_20060523.* - does the following: 
- changes the location of the composePolicyFile() calls so that there is ever only one call
(the method was being called twice, before)
- adds the property replacePolicyFile (true/false, default false, i.e. append)
- adds documentation in testing/README.htm for replacePolicyFile
- removes reference to serverPolicyFile property from jvm.java (because that property was
never used and the copying is now done in RunTest anyway)
- adds code to ensure a suite-specific policy file can also be used 
- adds a policy file for the nist suite and removes the entries from derby_tests.policy.

> add mechanism for specifying policy file for individual function tests
> ----------------------------------------------------------------------
>          Key: DERBY-892
>          URL: http://issues.apache.org/jira/browse/DERBY-892
>      Project: Derby
>         Type: Bug

>   Components: Test
>     Versions:
>     Reporter: Myrna van Lunteren
>     Priority: Minor
>  Attachments: DERBY-892_20060514.diff, DERBY-892_20060514.stat, DERBY-892_3_20060523.diff,
DERBY-892_3_20060523.stat, derby-892_pre.diff
> It would be nice to be able to specify a test-specific policy file.
> This should get handled similar to existing properties, i.e. get specified in a test_app.properties
file (or, for a suite, in the suite.properties file).  The file should then be copied into
the correct place.
> Note, that the 'old' functionTests harness (as opposed to junit tests) includes a check
for a property called 'serverPolicyFile' (in harness/jvm.java). The name is a left over from
when the policy file was only used for/by network server, and should be renamed - derbyTestPolicyFile,
for instance. It is not used anywhere at present, and not specific to network server. It would
be nice if this could be expanded, or, if not used, removed.
> The default policy file used is the derby_tests.policy file under functionTests/util.
> Also, currently, the property can only be used with RunTest - for further traction, it
should probably get passed on through RunSuite/RunList.
> Once confirmed to be working, the property should get documented in <trunk>/java/testing/README.htm.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message