db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew McIntyre (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-1078) Be able to build Derby when JAVA_HOME is set 1.6
Date Fri, 21 Apr 2006 01:27:06 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1078?page=comments#action_12375458 ] 

Andrew McIntyre commented on DERBY-1078:

Committed another patch with revision 395749 to get client and demo working with 1.3 when
compiled with 1.5 or higher. Unlike the engine, 1.3- and 1.4-dependent code are not well separated.
 So, fixed by asking the compiler to generate 1.3-compatible classes, but linked against the
1.4 runtime classes. Client now passes the jdbcapi suite. Also fixed demo just by switching
entirely over to 1.3. It was not dependent on any 1.4-specific methods.

This just leaves scouring the java/testing hierarchy for the remaining classes which should
be built as 1.3, but are currently compiled by a 1.4 dependent target. This is quite a few
tests, but they are easily identifiable because they error out immediately with UnsupportedClassVersionError.

> Be able to build Derby when JAVA_HOME is set 1.6
> ------------------------------------------------
>          Key: DERBY-1078
>          URL: http://issues.apache.org/jira/browse/DERBY-1078
>      Project: Derby
>         Type: Improvement

>   Components: Build tools
>     Versions:
>     Reporter: Rick Hillegas
>      Fix For:
>  Attachments: derby-1078.diff, derby-1078_part2.diff
> Currently, the 1.4 compiler is used to build most of Derby. We use the 1.6 compiler to
(optionally) build the JDBC4 support. If you try to build Derby in a shell window with a 1.6
JAVA_HOME, the 1.4 bits will fail to build. This is because those bits do not satisfy the
JDBC4 contract. In addition, even if you could build those bits under 1.6, the 1.6 class files
would fail to load on a 1.4 vm.
> We need to be able to use 1.6 as our default build environment but still generate jar
files which run on 1.4 and 1.5. There may be compiler switches which allow this. If not, building
in a 1.6 environment could fault in the 1.4 compiler as necessary.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message