db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew McIntyre" <mcintyr...@gmail.com>
Subject Re: build problem
Date Thu, 20 Apr 2006 23:34:00 GMT
On 4/20/06, Rick Hillegas <Richard.Hillegas@sun.com> wrote:
> Oh bother. I have synced up to revision 395720. That fixes the build
> problem, but now I'm getting UnsupportedClassVersionError again when I
> run jdbcapi/metadata.java under DerbNetClient on jdk1.3.

Yep, there's plenty of cleanup left to do. Turns out that separation
of JDK 1.3-dependent code from JDK 1.4-dependent code is poor
(non-existant?) in the client build, and there are quite a few java
tests that land on the wrong side of the fence as well.

We know it works on 1.3, so it's just a matter of getting all the
right classes segregated into 1.3-land and 1.4-land. So, bear with me
and I'll get them all separated. I'd suggest just not testing on 1.3
until I sound the all clear.

So: engine, tools, build, shared, and drda are done. That leaves
testing, client, and I want to double-check demo. Let me know if you
want to help out. ;-)

andrew

Mime
View raw message