db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew McIntyre" <mcintyr...@gmail.com>
Subject Re: [jira] Commented: (DERBY-1079) Build javadoc under jdk 1.6
Date Wed, 12 Apr 2006 20:22:23 GMT
On 4/12/06, Rick Hillegas (JIRA) <derby-dev@db.apache.org> wrote:
>
> Please help me understand the problem with the 3.2 grammar generator. I'm afraid I'm
not tracking this one. The following script raises identical errors run against Derby built
the old JavaCC (3.1) and the 3.2 version. Thanks-Rick

Sorry, it took me a bit to find the exact SQL that hit the bug, from
db2compatibility.sql:

VALUES 1..getClass()->getString();

Minor, I agree, but it's ugly to have the exception just fall out.
There was another case somewhere else, as well, i do believe, but it's
been a long time since I had looked at javacc 3.2.

As mentioned previously, why not go with 4.0? The RuntimeException
change only affects the mtGrammar parser used by the tests, no?

andrew

Mime
View raw message