db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepa Remesh (JIRA)" <derby-...@db.apache.org>
Subject [jira] Updated: (DERBY-514) Integrate upgrade tests into test suite
Date Fri, 21 Apr 2006 14:06:07 GMT
     [ http://issues.apache.org/jira/browse/DERBY-514?page=all ]

Deepa Remesh updated DERBY-514:
-------------------------------

    Attachment: derby-514-patch5-addtoderbyall.diff
                derby-514-patch5-addtoderbyall.status

Attaching a patch 'derby-514-patch5-addtoderbyall.diff' which adds upgrade test to a suite
and makes the upgrade suite part of derbyall. With this patch, I ran derbyall on Windows XP
with Sun JDK 1.4.2 and checked that the upgrade test passed. No other failures other than
the intermittent failure in lang/wisconsin.java. Please take a look at this patch.

I would appreciate if a committer who commits this patch can send out an alert to the community
with the below note:

NOTE: 
The pre-requisites to run upgrade tests:
* If the tests are run on a machine where the svn source is not available, a property 'derbyTesting.jar.path'
needs to be set in ant.properties file. Details are in Section 3.2 in BUILDING.txt.
* Upgrade test runs only with jar files in classpath. It fails when run with classes folder
in the classpath.






> Integrate upgrade tests into test suite
> ---------------------------------------
>
>          Key: DERBY-514
>          URL: http://issues.apache.org/jira/browse/DERBY-514
>      Project: Derby
>         Type: Test

>   Components: Test
>     Versions: 10.1.2.0, 10.2.0.0
>     Reporter: Kathey Marsden
>     Assignee: Deepa Remesh
>      Fix For: 10.2.0.0
>  Attachments: derby-514-buildfiles-v1.diff, derby-514-buildfiles-v1.status, derby-514-patch1-v1.diff,
derby-514-patch1-v1.status, derby-514-patch2-runtest-v1.diff, derby-514-patch2-runtest-v1.status,
derby-514-patch3-v1.diff, derby-514-patch3-v1.status, derby-514-patch3-v2.diff, derby-514-patch3-v2.status,
derby-514-patch4-sed.diff, derby-514-patch4-sed.status, derby-514-patch5-addtoderbyall.diff,
derby-514-patch5-addtoderbyall.status
>
> Currently there are no upgrade tests in the derbyAll suite.
> The upgrade tests java/testing/org/apache/derbyTesting are run by script and require
that the version to be tested by specified on the command line so that the classpath can be
changed.
> # runphases old_major old_minor old_engine new_engine
> #
> # e.g.
> #
> # runphases 10 0 c:/derby/10.0.2.1/lib c:/derby/trunk/jars/sane
> Perhaps this script can be rewritten in Java using class loaders and  previous Derby
verssions such as 10.0 and 10.1 be checked in so that this testing can   be incorporated into
the derbyAll test suite.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message