db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anders Morken (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-1174) NullPointerException in network server with LDAP authentication
Date Wed, 19 Apr 2006 09:30:00 GMT
    [ http://issues.apache.org/jira/browse/DERBY-1174?page=comments#action_12375081 ] 

Anders Morken commented on DERBY-1174:

Agreed. My quickfix "return if it's null" isn't very pretty, but it
worked for me when I played around in the debugger. But yes, I see that
it could surprise someone later if code unrelated to dbProps was added
below the conditional return. Thanks. =)

An enlightening comment. Hm. I'm still not sure if I fixed the symptom
or the the problem there. Is a null dbProps a normal situation when
Derby is started with "create=true" in the jdbc connect string? Will it
be null if you connect to an already created database without any
database properties set?

> NullPointerException in network server with LDAP authentication
> ---------------------------------------------------------------
>          Key: DERBY-1174
>          URL: http://issues.apache.org/jira/browse/DERBY-1174
>      Project: Derby
>         Type: Bug

>   Components: Network Server, Newcomer
>     Versions:,
>  Environment: Linux x86 (Fedora Core 4), 1.4.2_09 Sun JVM
>     Reporter: Anders Morken
>     Assignee: Anders Morken
>     Priority: Minor
>  Attachments: DERBY-1174.patch, derby.log, derby.properties
> While trying to fix DERBY-1000 I tried to set up Derby's network server to use LDAP authentication,
but I ran into something that looks like a bug, but could just as well be my own configuration
mistake. I would appreciate any help in figuring this out. =)
> The problem is a NullPointerException in the Network Server when it tries to initialize
the LDAP authentication service. The attached derby.log shows the exception and its stacktrace.
The attached derby.properties is what I put in the derby home directory.
> I'm seeing this problem in the trunk as well as my own build of the 10.1 branch and the release build available from the Derby web site. ( http://db.apache.org/derby/releases/release-
> The problem is cause by the setInitDirContextEnv method in JNDIAuthenticationSchemeBase
receiving a null dbProps argument, which it obviously doesn't expect. Adding a check for a
null dbProps argument and returning immediately after creating the initDirContextEnv object
fixes the NullPointerException and makes LDAP authentication work for me. This is a reasonable
enough robustness fix and shouldn't have any negative impact, but if the source of the problem
is that JNDIAuthenticationSchemeBase should never receive that null pointer in the first place,
more patching is needed. I'm not sure about this, so I'm leaving it up to the experts to decide
this. =)

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message