db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oystein Grovlen - Sun Norway <Oystein.Grov...@Sun.COM>
Subject Re: Soft Upgrade and Downgrade
Date Tue, 21 Mar 2006 09:11:32 GMT
Kathey Marsden wrote:

> There is some info here:
> http://db.apache.org/derby/papers/versionupgrade.html#Version+Upgrade+Mechanism

I did not understand the purpose of item 7 in the list that describes 
the behavior when the engine version is different from the on-disk 
version.  It says:

7. Requirement that EM <= 10 and DM >= 10.

Since EM < DM will cause the database not to boot (item 2), this seems 
to say that in order to boot the database EM == DM == 10.  In other 
words, all future release needs to be called 10.x.

-- 
Øystein

Mime
View raw message