db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@apache.org>
Subject Re: Error message on the derby.log while booting the database using jdk1.5
Date Sat, 11 Mar 2006 04:07:19 GMT
Manjula G Kutty wrote:

> Hi,
> I'm getting the following error message on my derby.log while booting a
> database using jdk15
> 
> *"Class org.apache.derby.jdbc.Driver40
> java.lang.UnsupportedClassVersionError: Bad version number in .class
> file, module ignored."
> *
> 
> I would like to know is this the same issue  as people discussed on the
> thread, with subject : Re: conflict between Derby API and JDBC 4.0?
> 
> Here is thre thread, but I don't know whether it has all the mails, this
> is my best try
> 
> http://mail-archives.apache.org/mod_mbox/db-derby-dev/200601.mbox/%3c43D6A0D4.50404@sun.com%3e.
> If so I would like to what is the solution to fix the problem.
modules.properties has this line to set the required version for that
class to be JSE 6

#jdbc4_optional_derby.env.jdk.jdbcJ6=6

but actually JSE 6 uses the constant 7 in Derby, not 6.

6 is for jdk15.

Trouble is we have 4 for jdk14 and 5 for jdk142.

I'll change the modules.properties.

Dan.




Mime
View raw message