db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From scott hutinger <S-Hutin...@wiu.edu>
Subject Re: Derby HTML book manuals - invalid anchors in TOC? (DERBY-753)
Date Thu, 02 Mar 2006 20:39:04 GMT
BTW, I think from what I have looked at, that it's best to fix the 
original problem rather than hack in fox (fop extensions), put titles in 
the fop output etc...

scott

scott hutinger wrote:
> I haven't looked at that file, but looking at the fop output, in the 
> getstarted file, bookmarks exist, which are not supported (from what I 
> saw) in the fo2xhtml.xsl file.
>
> <fo:block margin-left="9pc" text-align-last="justify">
> <fo:basic-link internal-destination="tgsrunningij">Running 
> ij<fo:leader leader-pattern="dots"/>
> <fo:page-number-citation ref-id="N105D5"/>
> </fo:basic-link>
> </fo:block>
>
> You will find that the basic-link doesn't have any 
> internal-destination, although it does have the page-number-citation 
> ref-id.
>
> <fox:bookmark internal-destination="N105D6">
> <fox:label>Running ij</fox:label>
> </fox:bookmark>
>
> <fo:inline id="N105D6"/>Running ij</fo:block>
>
> Although I think it has a off-by-one error in the fo:block with the 
> basic-link and the page-number-citation ref-id, which I am fairly 
> certain at one time or another, some of the dita transforms were off 
> by 1.  So it looks like if we used the bookmarks (implemented them in 
> fo2html.xsl) then the links would work.  Sound reasonable?
>
> This is just a quick fix, and I haven't looked at it enough to make 
> sure it works, it just looks like it would.  More than likely, some 
> other items need fixed in the transform to fop, which should be fixed 
> first.
>
> scott
>
>
>
> John Embretsen wrote:
>> Kristian Waagan wrote:
>>> Hello,
>>>
>>> Some time ago I created DERBY-753 
>>> (http://issues.apache.org/jira/browse/DERBY-753), but there has not 
>>> been any activity on it since then. It says that the links in the 
>>> table of contents of the HTML book manuals do not work.
>>>
>>> Can anyone confirm that the problem (still) exists?
>>
>> I can confirm that the problem still exists with the 10.2 reference 
>> manual. I have not tried the others.
>>
>> I also tried the link (from the Jira issue) that was supposed to 
>> work, but it did not work either. I.e.:
>>
>> http://db.apache.org/derby/docs/dev/ref/ref-single.html#crefsqlj95081
>>
>> does not work;
>>
>> http://db.apache.org/derby/docs/dev/ref/ref-single.html#N1223F
>>
>> does not work; but
>>
>> http://db.apache.org/derby/docs/dev/ref/ref-single.html#N1227F
>>
>> works.
>>
>>
>


Mime
View raw message