Andrew, thx for looking at this.
 
I was playing around with this a bit more, and I found that using the derbyTesting.encoding property this way only really works with jdk15.
(haven't tried jdk16).
With other jvms, using the test jdbcapi/resulset.java, the test will fall over with:
jdk13: > java.security.AccessControlException: access denied (java.util.PropertyPermission framework read)
jdk14: > java.lang.NoClassDefFoundError: ???????????????????????????????
ibm13: > java.lang.UnsatisfiedLinkError: ??: Can't find dependent libraries
> ???????????????????????????????????
ibm14 & ibm15: > ??????????????????????????????????????????????????????????????????????????????
????????????????????????????????????????
 
I'm not so interested in pursuing why things don't work with other jvms...Even as it is, only with jdk15, I still find this property useful. I was thinking of adding wrapping code to only use it if the jdk *is* 15. And I want to add some info to the java/testing/README.htm.
 
Does this seem reasonable?
 
Thx,
Myrna
 
P.S. - I checked with Deepa off-list, and she found during testing for DERBY-683 proper that the basic repro worked with jdk13 and jdk15, but not jdk14. She did not test with ibm jvms.
 
 
On 2/16/06, Andrew McIntyre (JIRA) <derby-dev@db.apache.org> wrote:
   [ http://issues.apache.org/jira/browse/DERBY-683?page=comments#action_12366662 ]

Andrew McIntyre commented on DERBY-683:
---------------------------------------

Hi Myrna, I can't get this patch (derby-683_021006.diff) to apply cleanly due to changes in RunTest. Could you merge your changes and post an updated patch?

> Use correct encoding for ClobOutputStream on client
> ---------------------------------------------------
>
>          Key: DERBY-683
>          URL: http://issues.apache.org/jira/browse/DERBY-683
>      Project: Derby
>         Type: Bug
>   Components: Network Client
>     Versions: 10.1.1.1, 10.1.1.0
>  Environment: all
>     Reporter: Sunitha Kambhampati
>     Assignee: Deepa Remesh
>      Fix For: 10.2.0.0
>  Attachments: ascii.txt, clob.java, derby-683.diff, derby-683_021006.diff, derby-683_021006.stat, derby-683_tests.diff, derby-683_tests.status
>
> In client, there is code in ClobOutputStream which uses this api - new String(byte[]).   Per the java api http://java.sun.com/j2se/1.4.2/docs/api/java/lang/String.html#String(byte[]) ,this will construct a string by decoding the array of bytes using the platform's default character set.
> org.apache.derby.client.am.ClobOutputStream is used for Clob.setAsciiStream and the write methods  use the String(byte[]) which is incorrect because it will use the default platform encoding. Per the jdbcapi , this should use ascii encoding.
> In areas related to Clobs, also check for other places where  String(byte[]) is used,as it may not be the desired behavior.
> Dan pointed this problem here : http://issues.apache.org/jira/browse/DERBY-463?page=comments#action_12356742

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
  http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira