db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Levitt <de...@mylevita.com>
Subject Re: Derby HTML book manuals - invalid anchors in TOC? (DERBY-753)
Date Mon, 27 Feb 2006 18:02:58 GMT
I can tell you that this is a problem that could be
hard to fix.  The single-html books are not a normal
result of the DITA transform.  However, some time ago
Andrew found an xsl file on the web that we were able
to use to transform the half-processed PDF transforms
from the DITA process and convert them to html. 
Unfortunately, since that XSL file came from outside
of DITA, it is not supported by their project.  If
someone has time they can try to modify that xsl file
to fix this problem, but I think the single-html files
were put in place as sort of a bonus when Andrew found
that xsl file, so I wouldnt expect to see as much
progress on the quality of those books as the other
two types of output, unless someone else knows what
they are doing and can fix this (I dont!) :)

Also, Andrew, do you know if the xsl file is legally
modifiable?


--- Kristian Waagan <Kristian.Waagan@Sun.COM> wrote:

> John Embretsen wrote:
> > Kristian Waagan wrote:
> >> Hello,
> >>
> >> Some time ago I created DERBY-753 
> >> (http://issues.apache.org/jira/browse/DERBY-753),
> but there has not 
> >> been any activity on it since then. It says that
> the links in the 
> >> table of contents of the HTML book manuals do not
> work.
> >>
> >> Can anyone confirm that the problem (still)
> exists?
> > 
> > I can confirm that the problem still exists with
> the 10.2 reference 
> > manual. I have not tried the others.
> > 
> > I also tried the link (from the Jira issue) that
> was supposed to work, 
> > but it did not work either. I.e.:
> > 
> >
>
http://db.apache.org/derby/docs/dev/ref/ref-single.html#crefsqlj95081
> > 
> > does not work;
> > 
> >
>
http://db.apache.org/derby/docs/dev/ref/ref-single.html#N1223F
> > 
> > does not work; but
> > 
> >
>
http://db.apache.org/derby/docs/dev/ref/ref-single.html#N1227F
> > 
> > works.
> > 
> > 
> 
> Okay, thanks for confirming the problem.
> For the links, the point was to illustrate that
> there are anchors in the 
> files, but they are not used. To me, it looks like
> there has been some 
> kind of mapping error or something during the build
> process.
> 
> I do not know how the anchors are defined and how
> the documentation 
> build process works. Can anyone with more Derby
> documentation building 
> experience see the reason for this problem?
> 
> 
> Since I believe we don't exactly score "Top rated"
> on our documentation, 
> I would say this problem should be fixed pretty
> quickly! It hinders 
> navigation severely.
> 
> 
> 
> --
> Kristian
> 


Mime
View raw message