db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Knut Anders Hatlen <Knut.Hat...@Sun.COM>
Subject Re: [jira] Updated: (DERBY-815) Prevent unneeded object creation and excessive decoding in parseSQLDTA_work()
Date Fri, 20 Jan 2006 08:55:56 GMT
Dyre.Tjeldvoll@Sun.COM writes:

>>>>>> "KAH" == Knut Anders Hatlen <Knut.Hatlen@Sun.COM> writes:
>     KAH> "Dyre Tjeldvoll (JIRA)" <derby-dev@db.apache.org> writes:
>     >> [ http://issues.apache.org/jira/browse/DERBY-815?page=all ]
>     >> 
>     >> Dyre Tjeldvoll updated DERBY-815:
>     >> ---------------------------------
>     >> 
>     >> Attachment: derby-815.stat
>     >> derby-815.diff
>     >> derbyall_report.txt
>     >> 
>     >> Ran derbyall with the usual failures. I'll let the committers decide
>     >> if it is ok to check in...
>     KAH> Hi Dyre,
>     KAH> Your patch definitely looks like an improvement. A couple of comments
>     KAH> of cosmetic nature, though...
>     KAH>   1) The files you have modified use tabs for indentation more or less
>     KAH>      consistenly, but you have used spaces. I think it's ok, but it
>     KAH>      makes the patch harder to read.
> Eh, what's your point? Do you want tabs or spaces? I'm not religious
> about it, I just thought people preferred spaces...

I prefer spaces myself, but I try to use the same indentation
character as the surrounding code to make the patch easier to read. As
I said, I think it's ok to do it like you did, I just stated the
obvious fact that the patch would have been more readable with

>     KAH>   2) CliParam's constructor and getCliParam() could use some line
>     KAH>      feeds.
> Beauty is in the eyes of the beholder :)

It is! Lines exceeding 80 characters have been commented so frequently
on the lists that I felt I didn't do a proper job of reviewing if I
didn't mention it. ;)

Knut Anders

View raw message