db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francois Orsini <francois.ors...@gmail.com>
Subject Re: Grant and Revoke, Part I ... DERBY-464...
Date Tue, 10 Jan 2006 19:19:15 GMT
I did not pick 'ansiAuthMode' because one could easily confuse 'Auth' for
Authentication instead of Authorization (these are 2 different beasts) -
hence why I leaned towards 'ansiAuthoMode' ;)

On 1/10/06, David W. Van Couvering <David.Vancouvering@sun.com> wrote:
>
> ansiAuthMode (not AuthoMode) sounds good to me, I agree that there is a
> false sense of security around the term secureMode.  How secure is
> secure?  And this is just about authentication and authorization,
> necessary but not necessarily sufficient in terms of security.
>
> David
>
> Francois Orsini wrote:
> > Agreed - I have had the same reserve but could not really come up with a
> > better name ;)
> >
> > Although I was thinking of 'ansiAuthorizationMode' (for ANSI
> > authorization mode) or 'ansiAuthoMode'
> >
> > On 1/10/06, *Daniel John Debrunner* < djd@apache.org
> > <mailto:djd@apache.org>> wrote:
> >
> >
> >     I'm still thinking about this 'secureMode' approach and the
> interaction
> >     with the existing authentication model. One issue I do have is the
> name
> >     of the attribute, 'secureMode'. I don't believe that the current
> >     grant/revoke syntax makes Derby completely secure, thus this
> attribute
> >     may mislead people. Note sure I have a better name though. :-(
> >
> >     Dan.
> >
> >
>
>
>

Mime
View raw message