db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dyre.Tjeldv...@Sun.COM
Subject Re: [jira] Updated: (DERBY-85) NPE when creating a trigger on a table and default schema doesn't exist.
Date Thu, 01 Dec 2005 09:03:48 GMT
"David W. Van Couvering" <David.Vancouvering@Sun.COM> writes:

> I got this too, I was pretty sure it was that junit is trying to read 
> system properties, the first one being "user.dir".  I think it also then 
> tries to read Junit properties out of the user's home directory?
>
> I spent some time trying to modify the test harness to indicate where 
> the third party jars were to try and fix this, but finally gave up and 
> turned off security manager for my JUnit test (I was going to log a 
> separate bug for this, I just didn't think it was worth spending all my 
> time trying to fix this right now).

I tried that too, but I could not get it to work. I tried setting
"noSecurityManager" to true, in all places that I could think of (prop
file, commnad line, and in the code itself), but I still got the same
errors.

After reading section 4.13 in the java/testing/readme.htm file I was
unsure about whether this property was used in embedded mode.

-- 
dt


Mime
View raw message