On 11/1/05, Bryan Pendleton <bpendleton@amberpoint.com> wrote:
Myrna van Lunteren wrote:
> I think your problem is indeed with db2jcc. Your sysinfo reports it's
> version 1.0:
>     "[/home/bpendleton/downloads/derby/db2jcc/lib/db2jcc.jar] 1.0 - (581)"
> I think we only support 2.4 and up with derby 10 and up. Try to download
> a later version if you need jcc.

Ah, good.

I was rather confused by this download step in my setup. The link
in java/testing/README.htm points to:

  http://www-128.ibm.com/developerworks/db2/downloads/jcc/

The link on this page asked me to register myself with IBM, which
I did, and then took me to

  http://www14.software.ibm.com/webapp/download/search.jsp?go=y&rs=cloudscape

There are 9 downloads listed on that page, so I went down the list and
found the thing that looked most likely to me:

  8.  Released product:   IBM Cloudscape (IBM DB2 JDBC
      Universal Driver, for Cloudscape/Derby)
      IBM Cloudscape V10.1 is a pure, open source-based Java relational
      database management system that can be embedded in Java programs and
      used for online transaction processing (OLTP)
      Operating system:  Java, Java2  | Version:   2.4.17  | Size:  1.03MB  |
       Release date:  04 Oct 2004

This certainly looks like it should be version 2.4.17.

When I clicked on that item, I get a file called db2jcc_for_derby.zip,
with a readme dated Sep 29, 2004, and jar files dated Aug 24, 2004:

-bash-2.05b$ ls -l /home/bpendleton/downloads/derby/db2jcc/lib
total 1064
-r--r--r--    1 bpendleton users     1077696 Aug 24  2004 db2jcc.jar
-r--r--r--    1 bpendleton users         673 Aug 24  2004 db2jcc_license_c.jar
-bash-2.05b$

But, as you point out, the Derby Information section in supersimple.diff
clearly states that I'm running version 1.0 of the driver:

--------- Derby Information --------
JRE - JDBC: J2SE 1.4.2 - JDBC 3.0
[/home/bpendleton/src/derby-subversion/trunk/jars/insane/derby.jar] 10.2.0.0 alpha - (315052M)
[/home/bpendleton/src/derby-subversion/trunk/jars/insane/derbytools.jar] 10.2.0.0 alpha - (315052M)
[/home/bpendleton/src/derby-subversion/trunk/jars/insane/derbynet.jar] 10.2.0.0 alpha - (315052M)
[/home/bpendleton/src/derby-subversion/trunk/jars/insane/derbyclient.jar] 10.2.0.0 alpha - (315052M)
[/home/bpendleton/downloads/derby/db2jcc/lib/db2jcc.jar] 1.0 - (581)
[/home/bpendleton/downloads/derby/db2jcc/lib/db2jcc_license_c.jar] 1.0 - (581)


So, I guess I'm confused: where did I go wrong, and what do I need
to do differently?

thanks,

bryan



Well, I'm confused too - it's too weird. I did the same thing you did but those same files on my windowze box show it's 2.4 (17). I plopped the zip file to a linux box & it works there too. file size & dates match to what you have...
Maybe sysinfo is misbehaving...or maybe the testharness?
I have very few suggestions to figure this out...none very good, I'm afraid.
1. do you get the same result when instead of running a test you do:
    java org.apache.derby.tools.sysinfo
  (it should get the same result, but...)
2. run the test not with the jars you just built, but use ant all and the resulting full directory in your classpath (but we did agree that we should all test with built jars before sub/committing).
3. ..sync up again, ant clobber and rebuild (software madness principles - do it again, and expect different behavior).
4. still working on further ideas... :-)
 
In the meantime, why don't you consider yourself mostly up and running. It is not required to use db2jcc to be a derby developer, although I'd hate to see the effort you put in already go to waste.
If you don't put db2jcc*.jar in the classpath, you can continue working...
 
Anyone else have any other suggestions?
 
Myrna