db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dyre.Tjeldv...@Sun.COM
Subject Re: Curious error trying to build derby source with JDK 1.5 on Linux (Sun JDK)
Date Sat, 12 Nov 2005 18:09:39 GMT
Bryan Pendleton <bpendleton@amberpoint.com> writes:

> As part of preparing to work on DERBY-666 I've been setting myself
> up to be able to build and test Derby using JDK 1.5.

You need to use JDK 1.4 to build Derby.

This is what I do:
In the shell where I plan to build Derby I source the following shell
script (you need to use the values that are correct on your system, obviously):

#!/bin/bash

set -x
export ANT_HOME=/usr/local/share/java/apache-ant-1.6.2
export PATH=$ANT_HOME/bin:$PATH
export JAVA_HOME=/usr/local/java/jdk1.4
set +x

Then in my ~/ant.properties I have

j14lib=/usr/local/java/jdk1.4/jre/lib
j13lib=/usr/local/java/jdk1.3/jre/lib
proceed=false
sane=false

There is, of course, many ways of achieveing the same thing,
e.g. create your own build shell script that handles this. 
 

HTH

-- 
dt


Mime
View raw message