db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David W. Van Couvering" <David.Vancouver...@Sun.COM>
Subject Re: DB2JCC, was: [jira] Updated: (DERBY-689) Various improvements to compatibility test.
Date Wed, 09 Nov 2005 16:33:55 GMT


Rick Hillegas wrote:
> Hi David,
> 
> Thanks for this improvement.
> 
> Right now, the DB2 JCC libraries are required for running the full set 
> of combinations. 

I'm not sure what you mean here.  The full set of combinations of what? 
Why is it required?

Thanks,

David

I don't understand Derby's long term relationship with
> this code. As we add new JDBC support (e.g., JDBC 4.0), we have no 
> control over the behavior of this client. Do we expect customers to 
> migrate onto Derby's client as of 10.1? I'm not aware of any discussions 
> about either continuing or sunsetting support for DB2 JCC.
> 
> Regards,
> -Rick
> 
> David W. Van Couvering wrote:
> 
>> Hi, Rick.  I've moved the compatibility test over to derbynetclient, 
>> as we agreed.
>>
>> I noticed in the testScript.xml for the compatibility tests that you
>> are asking for the location of the DB2 JCC libraries.  Is that required
>> or optional for running compatibility tests?
>>
>> I guess this asks the broader question of: are we required to 
>> guarantee backward compatibility with the DB2 JDBC driver as part of a 
>> release of Derby?
>>
>> Thanks,
>>
>> David
>>

Mime
View raw message