db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David W. Van Couvering" <David.Vancouver...@Sun.COM>
Subject ATTENTION: Revision 330103 requires junit.jar
Date Tue, 01 Nov 2005 18:17:08 GMT
Hi, all.  I just committed Rick's patch to DERBY-516 which adds support 
for compatibility testing.  These new tests are written in Junit and our 
build and testing infrastructure now requires the junit jar file to be 
downloaded and put into your classpath.

 From BUILDING.txt:

2.2.5 Download and install JUnit 3.8.*

(1) JUnit is needed for some of Derby's tests. Download a JUnit 3.8.*
     zip file from www.junit.org.
     Note that Derby has been successfully built with JUnit 3.8.1
     and we expect that other 3.8.* versions will work with our
     build process. The 4.* series of JUnit releases may not work
     until we fix the Derby build to accomodate the 1.5 extensions
     to java.

(2) Unzip the JUnit zip file and place junit.jar from the zip file into
     ${derby.source}/tools/java.


David


Mime
View raw message