db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Pendleton <bpendle...@amberpoint.com>
Subject Re: DERBY-516 patch and JUnit download
Date Thu, 13 Oct 2005 15:38:48 GMT
> Thanks for raising and addressing this issue. In specifying the JUnit 
> version, I was mimicking the way that BUILDING.txt treats Ant. I like 
> Dan's suggestion and I'll amend the scripts accordingly. I'll also amend 
> BUILDING.txt to say that the build succeeds with JUnit 3.8.1 but that 
> you can probably use the latest version available from JUnit.

This isn't probably a problem yet, but I think I've heard that JUnit 4
is a pretty massive change from JUnit 3. In particular, JUnit 4 switches
to usage of Java source annotations (the "@" syntax) for specifying
test behavior, and hence requires that you use JDK 1.5 or higher.

Since Derby probably doesn't want to require JDK 1.5 yet, we may actually
have a requirement to stick with JUnit 3 for a while.

thanks,

bryan




Mime
View raw message