db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathey Marsden <kmarsdende...@sbcglobal.net>
Subject Re: New Proposed 10.1 snapshot (was Re: lang/wisconsin.sql)
Date Thu, 06 Oct 2005 12:58:10 GMT
Deepa Remesh wrote:

>I ran derbyall with J2ME/CDC/FP with the new snapshot. 3 tests failed.
>I have attached the diff for failures.
>
>* derbyall/derbyall.fail:jdbcapi/metadataJdbc20.java (needs master file update)
>* derbyall/storeall/storeall.fail:store/oc_rec1.java
>(java.lang.IllegalStateException)
>* derbyall/storeall/storeall.fail:store/oc_rec3.java
>(java.lang.IllegalStateException)
>
>The stack trace for IllegalStateException from .tmp files:
>java.lang.IllegalStateException:
>	at java.util.zip.ZipFile.getEntryImpl(Native Method)
>	at java.util.zip.ZipFile.getEntry(ZipFile.java:142)
>	at java.util.jar.JarFile.getEntry(JarFile.java:307)
>	at java.util.jar.JarFile.getJarEntry(JarFile.java:209)
>	at java.net.URLClassLoader.findClassImpl(URLClassLoader.java:928)
>	at java.net.URLClassLoader$4.run(URLClassLoader.java:557)
>	at java.security.AccessController.doPrivileged(AccessController.java:167)
>	at java.net.URLClassLoader.findClass(URLClassLoader.java:555)
>
>  
>
>Has anyone seen this before?
>
>I tried to run the failed online compress tests individually but
>looking at the tests, I think they have to be run in sequence. So I
>ran just storeall suite and the tests oc_rec1.java and oc_rec3.java
>passed. I am not sure if these failures are intermittent. If anyone
>who has more knowledge of these tests can look into this and tell if
>this could be a problem in test/code, it would be great.
>
>  
>
I did a derbyall run with J2ME on my machine last night and it all
passed.   It seems to me that maybe this sis some sort of JVM issue.

The javadoc says IllegalStateException ...
"Signals that a method has been invoked at an illegal or inappropriate
time. In other words, the Java environment or Java application is not in
an appropriate state for the requested operation."

but I think that typically a subclassed exception would be thrown that
would give more information.  Also the fact that the trace itself seems
to just be loading a class and  has nothing to do with Derby,  I  think
is indicative of a JVM issue as well.  Mike,  is there some special
class loading stuff that goes on in this test that might cause this
issue to surface?


 I am using j9 from WCTME 5.7

$ j9 -version
java version "1.3.0"

Licensed Materials - Property of IBM

J9 - VM for the Java(TM) platform, Version 2.2
(c) Copyright IBM Corp. 1991, 2004  All Rights Reserved
Target: 20040706_1457_lHdSMR (Windows 2000 5.0 build 2195 Service Pack 4
x86)

Maybe my version is old.  Is this the version you are using?

Kathey



Mime
View raw message