db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From V Narayanan <V.Naraya...@Sun.COM>
Subject Re: [jira] Updated: (DERBY-587) Providing JDBC 4.0 support for derby
Date Wed, 28 Sep 2005 08:59:42 GMT
Hi,
The jdk1.6 dependency is optional in the patch. 

a) If the jdk16 variable is mentioned in the ant.properties file then the jdbc4.0 classes
are compiled 

b) If the ant.properties does not contain the jdk16 variable the compilation would proceed
the usual way.

I see that I have not mentioned the above in the document attached. I will add the above changes
to the document also attach it again to jira.

thanx
V.Narayanan




----- Original Message -----
From: Daniel John Debrunner <djd@debrunners.com>
Date: Tuesday, September 27, 2005 6:25 pm
Subject: Re: [jira] Updated: (DERBY-587) Providing JDBC 4.0 support for derby

> V.Narayanan (JIRA) wrote:
> 
> >      [ http://issues.apache.org/jira/browse/DERBY-587?page=all ]
> > 
> > V.Narayanan updated DERBY-587:
> > ------------------------------
> > 
> >     Attachment: jdbc40.diff
> >                 jdbc4.0.sxw
> > 
> > Hi,
> > I am attaching the patch for the JDBC4.0 STUB IMPLEMENTATION. 
> Also attached is a design document which explains the changes 
> incorporated and the classes and the build files affected due to this.
> 
> The document seems to imply that if this patch is applied I need to
> download JDK 1.6 to compile Derby. I do not believe this is 
> acceptable.Is there a jdk1.6 for MacOS for example?
> 
> Can the jdk 1.6 dependency be made optional? Like the OSGi and J2ME
> optional builds.
> 
> Dan.
> 
> 
> 
> 


Mime
View raw message