db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@debrunners.com>
Subject Re: [jira] Updated: (DERBY-587) Providing JDBC 4.0 support for derby
Date Tue, 27 Sep 2005 16:25:52 GMT
V.Narayanan (JIRA) wrote:

>      [ http://issues.apache.org/jira/browse/DERBY-587?page=all ]
> 
> V.Narayanan updated DERBY-587:
> ------------------------------
> 
>     Attachment: jdbc40.diff
>                 jdbc4.0.sxw
> 
> Hi,
> I am attaching the patch for the JDBC4.0 STUB IMPLEMENTATION. Also attached is a design
document which explains the changes incorporated and the classes and the build files affected
due to this.

The document seems to imply that if this patch is applied I need to
download JDK 1.6 to compile Derby. I do not believe this is acceptable.
Is there a jdk1.6 for MacOS for example?

Can the jdk 1.6 dependency be made optional? Like the OSGi and J2ME
optional builds.

Dan.




Mime
View raw message