db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepa Remesh <drem...@gmail.com>
Subject Re: platforms where Derby unit tests must run
Date Wed, 24 Aug 2005 18:18:15 GMT
I had submitted a patch for DERBY-398 to add instruction to run tests
on J2ME/CDC/Foundation. I missed adding the name of the jvm class
(j9_foundation) to the list of supported jvms in Section 4.9.

Also I see another jvm class j9_22 (IBM's J9 jdk 1.3.1 subset - 2.2)
in the code but it is not in the list. Is this jvm supported?

I can use the same JIRA issue to add this information.  

Thanks,
Deepa


On 8/24/05, Rick Hillegas <Richard.Hillegas@sun.com> wrote:
> Section 2.1 of  trunk/java/testing/README.htm gives instructions for
> running the Derby tests on
> 
> 1) jdk1.3.1 or higher
> 2) J2ME/CDC/Foundation
> 
> Further on in the same webpage, section 4.9 lists "supported jvms" where
> the tests have successfully run.
> 
> Is this accurate? More specifically, if we improve Derby's test
> infrastructure, what platforms do we expect the new infrastructure to
> support? What's good enough to start out with?
> 
> Thanks,
> -Rick
>

Mime
View raw message