db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Van Couvering <David.Vancouver...@Sun.COM>
Subject Re: Vote, please: Policy for supported platforms
Date Wed, 03 Aug 2005 00:29:42 GMT
Is 1.6 available?  I thought it was still "in process". 

David

Rick Hillegas wrote:

> Please vote on the following proposed policy for Derby's supported 
> platforms. Mostly, this proposal merely restates the current policy. 
> Changes are flagged.
>
> o 10.2 will be the LAST Derby release which runs on jdk 1.3 and 
> supports JDBC 2.0.
>   THIS IS A CHANGE FROM CURRENT POLICY.
>
> o 10.2 will run on the following platforms:
>
>  - J2ME/CDC/Foundation 1.0 (exposing the JDBC subset in JSR 169)
>  - 1.3.x (exposing JDBC 2.0)
>  - 1.4.x and 1.5.x (exposing JDBC 3.0)
>  - 1.6 beta (exposing JDBC 4.0) THIS IS A CHANGE FROM CURRENT POLICY.
>
> o To build 10.2, you MUST have the 1.3 and 1.4 sdks.
>
> o The 10.2 build will expose an optional target for building JDBC 4.0
>   support. To use this target, you must have a 1.6 sdk. THIS IS A CHANGE.
>
>
>

Mime
View raw message