db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Susan Cline (JIRA)" <derby-...@db.apache.org>
Subject [jira] Updated: (DERBY-476) Derby UI plug-in version 1.0.0 incompatible with Eclipse 3.1 M6 or higher
Date Fri, 29 Jul 2005 00:50:18 GMT
     [ http://issues.apache.org/jira/browse/DERBY-476?page=all ]

Susan Cline updated DERBY-476:

    Attachment: launch_patch.diff

The attached patch does two things:

1) Allows the Derby UI plug-in to work with Eclipse 3.1M6 and higher.  Since Eclipse 3.1 has
been GA since the end of June the Derby plug-ins should work with the current release of Eclipse.

Note that with this patch there is no support to run the Derby plug-ins on Eclipse 3.1M5 or

Without applying this patch when any of the functionality of the Derby UI plug-in is invoked
like starting the
Network Server, running ij, running sysinfo the following pop-up box appears (this example
is for the Network Server):

"Error starting Derby Network Server :
  Plugin org.apache.derby.ui was unable to load class

2) Update the version of the UI and Doc plugins to be 1.1.0 instead of 1.0.0.
      Since I'd like for these plug-ins to be released as zip files with the 10.1 release
of Derby, and the 10.1 Derby core plug-in, 
      I updated the version of the plug-ins to be 1.1, to make it more obvious the 1.1 UI
plug-in is compatible with the 10.1 Core plug-in.

Output from svn stat:

M      plugins\eclipse\org.apache.derby.ui\src\org\apache\derby\ui\launch\StopDerbyServerLaunchConfigurationDelegate.java
M      plugins\eclipse\org.apache.derby.ui\src\org\apache\derby\ui\launch\IJDerbyLaunchConfigurationDelegate.java
M      plugins\eclipse\org.apache.derby.ui\src\org\apache\derby\ui\launch\StartDerbyServerLaunchConfigurationDelegate.java
M      plugins\eclipse\org.apache.derby.ui\src\org\apache\derby\ui\launch\SysInfoDerbyLaunchConfigurationDelegate.java
M      plugins\eclipse\org.apache.derby.ui\plugin.xml
M      plugins\eclipse\org.apache.derby.plugin.doc\plugin.xml


I built a new UI and doc zip file and performed all of the manual tests here on the plug-ins:


I'd appreciate it is someone could review it, and if it looks okay, commit it.

> Derby UI plug-in version 1.0.0 incompatible with Eclipse 3.1 M6 or higher
> -------------------------------------------------------------------------
>          Key: DERBY-476
>          URL: http://issues.apache.org/jira/browse/DERBY-476
>      Project: Derby
>         Type: Bug
>   Components: Tools
>     Reporter: Susan Cline
>     Assignee: Susan Cline
>  Attachments: launch_patch.diff
> Per this email thread:
> http://mail-archives.apache.org/mod_mbox/db-derby-user/200506.mbox/%3c20050606165347.40256.qmail@web81302.mail.yahoo.com%3e
> The Derby UI plugin throws an exception when trying to start the Derby network server
with Eclipse 3.1M6 or higher.
> The fix for this is simple, and involves only changing a class name in 4 files per the
email above.  Eclipse 3.1 is now GA so this fix should be made to the UI plug-in which will
allow it to work with the current release of Eclipse.  
> Also, by adding this fix the plug-ins will no longer work with 3.0.x through 3.1M5 builds
of Eclipse.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message