db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Myrna van Lunteren <m.v.lunte...@gmail.com>
Subject Re: running tests with j9?
Date Thu, 12 May 2005 21:57:20 GMT
On 5/12/05, Daniel John Debrunner <djd@debrunners.com> wrote:
> Myrna van Lunteren wrote:
> 
> > Is it possible JAVA_HOME is pointing to another jvm?
> > It would be one situation where you'd get the error you mention.
> 
> Yep that was the problem, unsetting JAVA_HOME in my script fixed the
> problem.
> 
> > And then it is required to add the bootclasspath to the location of
> > the java.sql classes (e.g. database_enabler.jar), which is an
> > additional package, or you'll get java.sql.SQLException not found. If
> > you either specify the other main jvm libraries (classes.zip,
> > charconv.zip) in the bootclasspath, or specify the java.sql jar/dir
> > explicitly in combination with -jcl:max it will work better.
> >
> > So: j9 -jcl:max
> > -Xbootclasspath/p:c:/wsdd5.6/ive/lib/database_enabler.jar
> > -Dbootcp=c:/wsdd5.6/ive/lib/database_enabler.jar
> > org.apache.derbyTesting.functionTests.harness.RunTest ...
> 
> The above worked for me, but in my wsdd5.6 distribution
> database_enabler.jar was under ive/lib/jclMax.
I think when I downloaded wsdd5.6 I actually got a directory with
java.sql.* under jclMax. database_enabler.jar was a separate effort
but supposedly the same.
> 
> In WCTME 5.7, however it is under ive/lib
> 
With wctme5.7 downloading the java package did not give a directory,
like wsdd5.6, but database_enabler.jar (to be used with jclMax). I
think it ended up under features in the tool for me. I never
questioned the packaging.
> One more question, how does the test harness map from the j9 vm to the
> j9_13.java representation of the JVM?
> 
> Onto CDC/Foundation ...
Note that with foundation, with wsdd5.6 there is no support for
java.sql.* (you'll get an incompatible library error if you try) and
with wctme5.7 foundation you are supposed to use jdbc.jar (again,
database_enabler.jar will give incompatible library with jclFoun).
Jdbc.jar does not have (for example) java.sql.DriverManager as that
class is not in JSR169. So with foundation you have to run the test
harness with java.sql.DataSource. I've never tried that.
> 
> Thanks,
> Dan.
> 
> 

Myrna

Mime
View raw message