db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathey Marsden <kmarsdende...@sbcglobal.net>
Subject Re: [jira] Commented: (DERBY-205) Rename org.apache.derby.impl.drda.DB2jServerImpl to NetworkServerControlImpl
Date Mon, 23 May 2005 21:34:30 GMT
Dag H. Wanvik (JIRA) wrote:

>     [ http://issues.apache.org/jira/browse/DERBY-205?page=comments#action_66070 ]
>Dag H. Wanvik commented on DERBY-205:
>205b.diff does this:
>- Removed the (redundant) reading of these stream name properties from
>  NetworkServerControlImpl.java:
>            derby.stream.error.file
>	    derby.stream.error.method
>	    derby.stream.error.field
>- Modified DRDAConnThread.java to get the stream name via
>  Monitor.getStream().getName (a new method). DRDAConnThread was the
>  sole client and reason for the redundancy Kathey spotted.
>- Augmented HeaderPrintWriter interface with a new method, getName.
>- Augmented BasicHeaderPrintWriter to hold the stream name of the
>  error log.
>- Moved hard coded constants for the stream name attributes from
>  SingleStream.java to the Property interface and documented them there.
>- Removed the errorLogLocation field and the getErrorLogLocation from
>  NetworkServerControlImpl.java
>- Cleaned up some Javadoc for the items I touched.
>I have run derbyall with JDK1.4.2 on Solaris/x86. derbyall runs with
>errors, but the same errors are present on a clean checkout as well
>(parameterMapping, backupRestore1). Hope somebody cleans that up...
>I could not see that the tests tested either the ".method" or the
>".field" propeties in any way, and thus not the precedence relation
>between them either. It could be a good idea to add tests for that,

This is a very nice patch and certainly goes above and beyond the call
of duty for Derby 205.
Although the cleanup looks great, I am  concerned about cleaning up the
handling of these properties if we don't have tests.  Could you
add a simple test?



View raw message