db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@debrunners.com>
Subject Re: running tests with j9?
Date Fri, 13 May 2005 18:08:51 GMT
Myrna van Lunteren wrote:
> After a night's sleep, I realize you probably need to have a jvm class
> for j9_foundation for wctme5.7. We had such a jvm class in the harness
> dir with earlier cloudscape versions for wsdd5.0 or wsdd5.5, but with
> wsdd5.6 the combo jcl-java.sql was not supported, so I didn't
> contribute that class.
> 
> I should probably make one for wctme5.7 - jcl foundation. Or are you
> working on it already?

I was heading towards it, but I'm sure you could get it done a lot
quicker than I can. So, please go ahead.

Though, I do see this as a flaw with the test harness, that some code
may need to be written to test Derby on a new VM. Creates a barrier to
anyone wanting to test on a new VM, especially outside to confines of
the usual VMs. That's why I would like Derby to move to JUnit.

Thanks,
Dan.


Mime
View raw message