db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean T. Anderson" <...@bristowhill.com>
Subject Re: [patch] [doc] updatable ResultSets [having trouble applying patch]
Date Thu, 05 May 2005 03:32:53 GMT
I'm having trouble applying this patch, but perhaps I'm not getting the 
patch syntax correct. I've succeeded previously applying Jeff's patches 
that modified just one file, and this is the first time I have tried to 
apply a patch that modifies more than one file.

So, it modifies three files relative to the current working directory:

    [jta@gertie3 ref]$ grep "^Index:" resultsets_changes.diff
    Index: rrefjdbc77156.dita
    Index: rrefcorrelationname.dita
    Index: rrefcolumnname.dita

So I put the patch in trunk/src/ref , then tried to apply it but there 
are a couple failures:

    [jta@gertie3 ref]$ patch -i resultsets_changes.diff
    patching file rrefjdbc77156.dita
    Hunk #4 FAILED at 166.
    1 out of 4 hunks FAILED -- saving rejects to file rrefjdbc77156.dita.rej
    patching file rrefcorrelationname.dita
    Hunk #1 FAILED at 19.
    1 out of 1 hunk FAILED -- saving rejects to file 
rrefcorrelationname.dita.rej
    patching file rrefcolumnname.dita

what's the right way to debug this? I attached the two reject files.

By the way, I tried to apply this with the DITA source at revision 
168249. Jeff, what was the revision of your local copy when you produced 
the patch? --There is a backlog of patches to apply in Jira (and which 
I'll try to catch up on). I'm wondering if it's possible this patch 
depends on one of those and I'm applying it out of order.

thanks,

  -jean


Mime
View raw message