db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@debrunners.com>
Subject Re: Question for testing upgrade db
Date Thu, 05 May 2005 00:09:08 GMT
TomohitoNakayama wrote:

> Hello.
> 
> I have implemented patch for DERBY-167 and try to test upgrade db.
> 
> Connecting previous database , next error occured.
> 
> ij version 10.1
> ij> connect 'jdbc:derby:testdb';
> ERROR XJ040: Failed to start database 'testdb', see the next exception
> for details.
> ERROR XCW00: Unsupported upgrade from '10.0' to '10.1 beta'.
> ij>
> 
> This seems that it is impossible to test upgrade db at current trunk ....
> 
> Can I take any other way ?
> Please give me some advise...

I added a property just for this, based upon a similar concern by Suresh.

Set the system property

derby.database.allowPreReleaseUpgrade=true

e.g.

java -Dderby.database.allowPreReleaseUpgrade=true org.apache.derby.tools.ij

I checked this in and an initial form of an upgrade test, but I haven't
had time yet to describe it to the list.

Dan.



Mime
View raw message