db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Susan Cline <home4...@pacbell.net>
Subject [PATCH] plugin.xml file for Derby Core plug-in is not in sync with plugin itself
Date Mon, 02 May 2005 20:44:16 GMT
Andrew committed the new derbyclient last week and updated the
snapshot jars, including the Eclipse plug-in.  When I downloaded
the derby_core_plugin_10.1.0.165185.zip file I noticed that
the plugin itself now contains derbyclient.jar, but the plugin.xml does not
list it as one of the libraries of the plugin.

Without the addition of derbyclient.jar in the plugin.xml,
the derbyclient.jar file can not be used by the plugin.

This patch remediates this problem and allows derbyclient.jar
to be used by the Apache Derby Core 10.1 plug-in.

Tests run: verified the built plugin.xml file is well formatted
and includes derbyclient.jar. Verified, using sysinfo, the jars
contained in the plugins/org.apache.derby.core_10.1.0 directory
are 10.1.0.0 alpha jars.

This is my first patch, and although trivial, if I've done anything 
incorrect
please let me know.  Also, if this patch is acceptable, could a committer
please commit?

Thanks,

Susan

Output of svn stat:
M      java\build\org\apache\derbyBuild\eclipse\DerbyEclipsePlugin.java

Patch attached.


Mime
View raw message