db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dag H. Wanvik (JIRA)" <derby-...@db.apache.org>
Subject [jira] Commented: (DERBY-205) Rename org.apache.derby.impl.drda.DB2jServerImpl to NetworkServerControlImpl
Date Mon, 23 May 2005 15:58:52 GMT
     [ http://issues.apache.org/jira/browse/DERBY-205?page=comments#action_66070 ]
Dag H. Wanvik commented on DERBY-205:

205b.diff does this:

- Removed the (redundant) reading of these stream name properties from


- Modified DRDAConnThread.java to get the stream name via
  Monitor.getStream().getName (a new method). DRDAConnThread was the
  sole client and reason for the redundancy Kathey spotted.
- Augmented HeaderPrintWriter interface with a new method, getName.
- Augmented BasicHeaderPrintWriter to hold the stream name of the
  error log.
- Moved hard coded constants for the stream name attributes from
  SingleStream.java to the Property interface and documented them there.
- Removed the errorLogLocation field and the getErrorLogLocation from
- Cleaned up some Javadoc for the items I touched.

I have run derbyall with JDK1.4.2 on Solaris/x86. derbyall runs with
errors, but the same errors are present on a clean checkout as well
(parameterMapping, backupRestore1). Hope somebody cleans that up...

I could not see that the tests tested either the ".method" or the
".field" propeties in any way, and thus not the precedence relation
between them either. It could be a good idea to add tests for that,

> Rename  org.apache.derby.impl.drda.DB2jServerImpl to NetworkServerControlImpl
> -----------------------------------------------------------------------------
>          Key: DERBY-205
>          URL: http://issues.apache.org/jira/browse/DERBY-205
>      Project: Derby
>         Type: Task
>   Components: Network Server
>     Versions:
>     Reporter: Kathey Marsden
>     Assignee: Dag H. Wanvik
>     Priority: Trivial
>  Attachments: 205b.diff
> For historical reasons the class DB2jServerImpl, which implements the public NetworkServerControl
interface is  inappropriately named.  It should be renamed to NetworkServerControlImpl

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message