db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dibyendu Majumdar" <dibye...@mazumdar.demon.co.uk>
Subject Re: Pooled connections are closed?
Date Thu, 05 May 2005 23:57:58 GMT
Oops - sorry - different problem.
----- Original Message ----- 
From: "Dibyendu Majumdar" <dibyendu@mazumdar.demon.co.uk>
To: "Derby Development" <derby-dev@db.apache.org>
Sent: Friday, May 06, 2005 12:13 AM
Subject: Re: Pooled connections are closed?


> Hi,
>
> I have created an issue for this (DERBY-246).
> Basically, the XA implementation seems broken, and behaviour is the same
as
> that of DB2 type-4 driver against a DB2 database.
>
> Regards
> ----- Original Message ----- 
> From: "David Van Couvering" <David.Vancouvering@Sun.COM>
> To: <derby-dev@db.apache.org>
> Sent: Thursday, May 05, 2005 11:55 PM
> Subject: Pooled connections are closed?
>
>
> > Hi, all.  I'm working on testing the toString() fix for Connections.
> > I'm trying to cover all the bases in terms of our various data sources.
> >
> > In my tests I create a new instance of EmbeddedXADataSource and
> > ConnectionPoolDataSource, and then get an XAConnection and a
> > PooledConnection.  From each of these I then call getConnection().  I am
> > not sure if this is right, but I'm copying existing test code here.
> >
> > All this works great, except that the first connection I get back from
> > getConnection() is always closed.  Does anyone know why this is?  Is
> > this expected behavior?
> >
> > Thanks,
> >
> > David
>
>
>



Mime
View raw message